We are continuing to monitor for any further issues.
Posted May 22, 2025 - 23:58 UTC
Monitoring
A fix has been implemented, and we're monitoring the results. API performance should be back to normal, although app creates may still be degraded.
Posted May 22, 2025 - 22:03 UTC
Update
We're continuing to work on fully restoring the Machines API. API calls are still taking longer than usual but we're no longer seeing failures.
Posted May 22, 2025 - 21:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2025 - 19:58 UTC
Identified
We identified an issue while migrating our production traffic, and have applied a fix to restore dashboard functionality. We're continuing to work on fully restoring the Machines API.
Posted May 22, 2025 - 19:01 UTC
Update
The Fly Dashboard is also affected and may prevent certain dashboard functionality, like the support portal. If you're on a paid support plan, please submit tickets using your support email address in the meantime.
Posted May 22, 2025 - 18:37 UTC
Investigating
We’re migrating production traffic over to a new production database. GraphQL queries, including flyctl commands, may be slow.
Posted May 22, 2025 - 18:32 UTC
This incident affected: Dashboard, Machines API, and Deployments.